VisCon documentation

VisCon documentation

VisCon documentation

Thomas byskov Dalgaard

Nicklas Tegner

Accessiware

(C) Copyright 2019-2020, Accessiware, All rights reserved.

Last updated: 2020-11-06 for VisCon version 1.0.5.

Preface

Please note that this version of VisCon is a concept release. This means that the program is fully functional, and we really want you to give it a testdrive. This release is focused on showing our ideas and a concept of what VisCon can do. We have plans for future versions already, but we really need feedback from users of VisCon, so we can spend time on the features you want. Therefor we decided to make this first release as a concept release, so you can get the concepts and ideas on how VisCon is intended. If you have any feedback, feature request or you have found a bug, then please contact us! We can’t wait to hear from you!

Introduction

Thank you for your interest in VisCon. We hope you will find it useful in your day-to-day tasks.

How to read this manual

This paragraph will explain the structure of this manual.
In the next chapter “Installing VisCon” you will learn how to install VisCon on to your computer.

In the chapter “Getting started with VisCon” we will dive into VisCon and explain the menus and how VisCon works in general.

In the chapter “Working with documents” you will learn about the more sophisticated tools VisCon offer such as working with multiple documents, change preferences, watching document statistics and more.

In the appendix 1 “Introduction to Markdown”](#appendix-1) you will find additional information about the Markdown syntax. This appendix is a must read if Markdown is all new to you.

In Appendix 2 [“Version history”][#changelog)

What is VisCon?

VisCon is at its core, a word processing program. The difference between VisCon and other word processing programs is that VisCon uses a markup language to format your documents, which may sound a little advanced, but it is quite easy to learn in a short time, and there are several benefits taking advantage of this Model

You can always get VisCon to create a document that suits another program. For example, if you want to send your document to someone who prefers to use Microsoft Word, VisCon ensures that the document is converted to a regular Word document that can be opened in any newer version of Microsoft Word. VisCon supports Microsoft Word 2007 or later editions. All you have to do is save your document as a Word document, then VisCon will handle the rest of the work for you. In the chapter “Working with documents”, you will find detailed information on how to work with documents in VisCon. However, VisCon does most of the conversion by itself so in most cases you will never have to think about converting your documents.

Conversely, you can also open a Word document in VisCon, which will itself convert it to the markup language so that you can make changes or save a copy before making any changes to the document.

Why learn a markup language?

VisCon is built around the Markdown markup language. Markdown is a simple way to format text. Markdown was originally invented because one would like to have a simpler way to format Web pages. Over time, however, many others have also found that Markdown could be used for other cases than websites, which VisCon is an excellent example of. With VisCon you can both get web content done, but you can also use it for formatting purposes. So be creative and try all the use cases you can think of with VisCon. And please share your experiences with us and other users.

All of this documentation has been prepared in Markdown in VisCon. In Appendix 1 you will find a general introduction to Markdown and useful external resources which may help you learn the basics of Markdown.

To illustrate how simple this markdown markup language is, see the following example.

Here we have an ordered list with three items.

First you will see how the list should be written. Then you see the result.

To write a list:

1. Here is the first list item.
2. Here is the second list item.
3. Here is the third list item.

The result looks like this:

To write a list:

  1. Here is the first list item.
  2. Here is the second list item.
  3. Here is the third list item.

As you see above, the markup of the list items is very simple and similar to what most would even write when an ordered list is wanted. In other word processing applications, these will even guess when you want to make a list like the one you see in the example above. Often, you don’t have to be aware of when you write content in your document, or when you edit the formatting and layout of your document.

One advantage is that you can work on your document from any device you may have access to. The only requirement VisCon asks is that the document is saved as plain text or Markdown. It can be done from virtually any computer, mobile phone or tablet.
So you are sure that the document you are working on can be opened and edited no matter what device you are working from.

Another advantage of using VisCon is that you gain full control over the layout and structure of your document. No unwanted surprises while composing and editing your documents. At the moment you cannot define fonts inside VisCon, but you can structure and organise your documents.

We strongly recommend that you experiment with VisCon so that you can judge and evaluate the results with your own eyes. VisCon is one of the tools that can be very difficult to describe, but once you see it in practice, the understanding comes quite quickly.

Highlighted features

With VisCon, you are able to perform the following tasks, among other things:

  • Create nice looking documents directly from your computer keyboard.

  • Convert documents to popular formats such as Microsoft Word, RTF, Open document (ODT) or nice looking HTML-documents.

  • Preview your documents in your web browser of choice.

  • Export documents to a variety of formats such as Microsoft Word, HTML, Rich text format or Open document (ODT).

  • Import documents from Microsoft Word, RTF, ODT, HTML or opening plain text files.

    Installing VisCon

VisCon is available for both Windows and Mac OS.

VisCon requires at least Windows 7 (32 or 64-bit) or Mac OS 10.9 (Mavericks) or later to function properly.

You can find VisCon for your operating system on VisCon’s download page
The program installs like most other programs according to your operating system. For more information on installation, see the following sections for Windows and Mac.

Installing VisCon on Windows

To install VisCon on Windows, follow these steps:

  1. Visit the following website:
    http://visconapp.com/download
  2. Find and activate the link: “Download VisCon for Microsoft Windows”.
  3. Download the file as usual with your Web browser.
  4. Now Find the file that you just downloaded. This is called: VisCon-Windows-Installer.
  5. Double-click (or press Enter on the file) and follow the onscreen instructions to complete the installation of VisCon.
  6. When the installation is complete, you can open VisCon.

Congratulations! You can now start using VisCon.

Installing VisCon on Mac OS

To install VisCon on Mac OS, follow these steps:

  1. Visit the following website:
    https://visconapp.com/download

  2. Find and activate the link: “Download VisCon for Mac OS X”.

  3. Download the file as usual with your Web browser.

  4. Now Find the file that you just downloaded. This is called: VisCon-Mac-installer.

  5. Open the file by double-clicking on it (or from the keyboard press command-O).

  6. Copy the VisCon file into the Applications folder on your Mac.

  7. Hold down the CONTROL key while clicking the VisCon file. Click the “open” button to complete the installation of VisCon on your Mac.

    Note: If you are using VoiceOver (the screenreader on Mac OS) you will need to press VoiceOver-shift-M to bring op the context menu and from here select “Open.” Now confirm that you want to run VisCon, by locating the “Open” button and activate it with VoiceOver-spacebar..

Congratulations! You can now start using VisCon.

Getting Started with VisCon

This chapter will teach you about various basic features and capabilities of VisCon.

To find detailed information on how to work with Markdown in VisCon it is highly recommended that you read the chapter “Overview over VisCon Markdown” But do not try to master it all at once. Instead, try to do some specific tasks with VisCon. For instance. Try to make a document with a few headings, paragraphs and even a bulleted list. Use the chapter as a reference guide and just keep practicing. All of a sudden you will understand the basics, and it will be easier for you to get your documents done.

In the following paragraphs, we will explore the menus. In the next chapter “Working with documents” you will find detailed information about some of the concepts VisCon uses to import, export and preview documents.

VisCon is visually very simple. At the top of the screen is a menu bar from which all functions can be accessed. The menus and their functions are explained in the following sections.

Note: When you examine the menus in VisCon, you will see that there are hotkeys for the vast majority of functions. For example, you can press CONTROL + N (on Windows) or command-N (on Mac OS) to create a new document rather than clicking the File menu and then clicking “New” with the mouse. Using the keyboard as you type can be a good way to increase the pacing of your work.

The VisCon menu: Mac OS only

The menu structure on Windows and Mac OS differ due to the way the operating systems work. On Mac OS you will therefore have a VisCon menu that will not be visible in the Windows version. The menu items in this menu are located in other menus in the Windows version.

  • About: Shows relevant information about VisCon such as which version you are running - and where to find VisCon on the web.
  • Preferences: Shows VisCon preferences. In here you can change the interface language and other settings. For more information see (VisCon preferences)
  • Quit VisCon: Exits VisCon. If you have one or more open documents that are not already saved, VisCon will prompt you for each document before exiting. This is done so that you do not inadvertently lose any of your open documents.

The File Menu

The File menu contains the following menu items:

  • New: Creates a new document.

  • Open: Allows you to open a document from anywhere on your computer.

    Note: If you select a document that is not a plain text document (with the txt extension) or a Markdown document (with the md extension), VisCon will automatically attempt to convert the document you open to Markdown.
    Thus, if you open a Word document with VisCon you will see a converted document showing how the document looks in Markdown. You can freely change the text and layout of the document accordingly. For more information see: Importing documents into VisCon

  • Save: Saves your current document. If the document does not already have a name, the “Save as” dialog box will open automatically.

  • Save As: presents you with a dialog box where you can give your document a name and choose its format. If you select Markdown or plain text, your document will remain unchanged. The only exception to this rule, is if you change the settings for text encoding under the Advanced category in Preferences. If you save in any other supported format, VisCon will automatically convert your document to the format you have selected. For more information read Exporting your document

  • Exit: Exits VisCon. If you have one or more open documents that are not already saved, VisCon will prompt you for each document before exiting. This is done so that you do not inadvertently lose any of your open documents.

    Note: This menu item is only shown in the Windows version of VisCon.

The Edit Menu

The Edit menu contains the following menu items:

  • Undo: Will undo the last edit you have done. This includes last keypress etc.

  • Redo: Will redo the last edit you have done. This includes last keypress etc.

  • Cut: Cuts the selected text to the clipboard.

  • Copy: Copies the selected text to the clipboard.

  • Paste: Paste the contents of the clipboard to the cursor position.

    Tip: If you are pasting contents which was copied from another application all formating will be ignored, so only the plain text is kept. Linebreaks will be preserved.

  • Select All: Selects all contents in the current document.

  • Search: Opens a screen with the following options:

    • Find what: Here you can enter text to search for. Press enter to activate the “Find next” button.
    • Match whole word only checkbox: If you check this checkbox only entire words will be matched. This checkbox is unchecked by default.
    • Match case checkbox: If this checkbox is checked the search will try to match upper and lowercase results. This is useful if you for example search for a word that begins with a capital character. This checkbox is unchecked by default.
    • Find next: Searches the document and places the cursor at the next match. This button can be triggered directly from the search field by pressing the enter key.
    • Cancel: Closes the screen. Press escape on the keyboard to activate this button.
  • Find and replace: Search for some text and type something else to replace any matches. The window contains the following options:

    • Case sensitive checkbox: Allows you to choose if you want the search and replace matches to be case sensitive or not. This is unchecked by default.
    • Find what: Here you can type in the text you want to search for.
    • Replace with: Type the text you want to be replacing the search matches.
    • Replace: Will search and replace.
    • Cancel: Will cancel and close the window and return you to the VisCon main window.

The Insert Menu

This menu is useful when you are learning the Markdown markup language. However, to get the most out of the markup formating VisCon provides, use the appendix 1 “Introduction to Markdown”](#appendix 1-an-introduction-to-markdown) as a reference guide.

The insert menu has the following items:

  • Headings: This is a submenu where you can choose among six heading levels. Level 1 is the biggest type of headings. When you choose a heading level the Markup syntax will be inserted at the cursor position, and you can then start typing the content for the heading.
  • Lists: This submenu allows you to select different types of lists. These are the following:
    • Ordered list: Inserts a list with four empty items starting from 1. to 4. You can add as manny items as you wish to this list.
    • Unordered list 1: Creates a bulleted list with the - as a list marker.
    • Unordered list 2: Creates a bulleted list with the * as a list marker.
  • Links: This submenu allows you to insert links. You have the following options:
    • Raw link: This will insert http://url.com you will need to change the link accordingly. The link will be converted to a clickable link as long as the< and > characters are placed around the url.
    • Inline link: Will insert a more friendly URL where you can add a text to the link. Simply change the text between the two brackets to whatever you like. Then change the URL which is put between two regular square brackets.
  • Blockquote: Lets you insert a quote in a classic blockquote.
  • Image:

The Tools menu

The tools menu contains the following items:

  • Preview: Previews the current document in your default web browser. This is a good way to watch your formating and structure before sharing or converting your document to an alternative format. For more information see: Previewing a document from VisCon
  • Document statistics: This is very useful if you are working on a document which has specific needs, such as a maximum of words, characters or number of pages. The document statistic window will show you the following details about your document:
    • Lines: Shows the number of lines your document contains.
    • Pages: Shows the number of pages.
    • Characters: Displays the amount of characters including linebreaks, spaces etc.
    • Characters without spaces: Displays the number of characters excluding linebreaks and spaces.
    • Words: The number of words in your document.

The Help Menu

  • About: Shows relevant information about VisCon such as which version you are running - and credits.

  • Preferences: Shows VisCon preferences. In here you can change the interface language and other settings. For more information see (VisCon preferences)

  • What’s new: Opens a webpage displaying all information about each released version of VisCon. This is very useful if you want to know what has changed since the last update. After an update this website will be launched automatically.

  • Check for updates: Allows you to check for updates manually. Note however that VisCon by default will check for updates every time you start the application.

    When an update is found VisCon will tell you that an update is ready for you to install. Simply answer yes to download and install the update. First you will see a dialog which shows you the status of the download. When the update is downloaded, VisCon will exit, and you will be asked to allow the update to be continued. On Windows this is done by allowing VisCon via the User Account Control dialog. On Mac OS, you will need to enter your user account password. When VisCon is updated, you will see a dialog box where a change log is displayed. Just press enter, and you are back to VisCon.

    Note: If there are any open documents, VisCon will ask you to save, before the update can take place. This is done, so you wan’t loose your work.

  • Go to our homepage: Will open your web browser of choice on the VisCon website at: https://visconapp.com

    Working with documents

In this chapter we will discuss some of the more advanced features in VisCon. We will begin by explaining how to import and export documents, then you will learn how to work with multiple documents and how to preview one or more documents. At last we will look at the preferences dialog

Importing documents into VisCon

You import a document by doing the following:

  1. Go to the file menu and choose “Open” or “Open from URL.” Alternatively, you can press command-o on Mac or control+o on Windows to get the open dialog box.
  2. Find the file that you want to open in VisCon
  3. Choose “Open” or if you are using the keyboard press enter/return on the filename.
  4. Now the file is opened and imported into VisCon.

As soon as you open a supported file format that isn’t plain text (.txt or any markdown format) VisCon will recognize the file format and import it. When VisCon imports a document it will convert it from its format into Markdown. The result is that you will see the converted document inside VisCon after a few seconds. Note that fonts and other special formating is ignored at the moment.

You may wonder why VisCon automatically imports your document and converts it into Markdown. The reason for doing so is for ensuring that all the structure is stored even after the conversion. By structure, we are specifically referring to headings, lists, links, paragraphs and so on.

If you ever have collaborated with others, using different word processors, you may have encountered how frustrating it is when some of the layout has changed as soon as one updated the document. If you import (or open) the document in VisCon you will know that all of the structure is kept. You can edit the content of the document and preview the result of your work in your favorite web browser.

If you are working with someone and they update the document you both are working on via a Cloud storage provider, it is very easy for you to get the changes they made.

  1. When you know the document is updated, simply just move to your desktop or any other open application and back to VisCon again.
  2. VisCon shows you a dialog saying that the document you are viewing has been changed. You are now given the option to reload the document.
  3. If you choose “Yes,” your document is reloaded and all changes are present.
  4. If you choose “No,” then your currently edited version stays present.

Note: If you both write in the same document at the same time and save conflicts will almost happen. VisCon can not avoid this. But it can certainly help you track changes in documents. We therefore, recommend that you find a workflow where conflicts aren’t likely to happen. For example: Let the other person make suggestions in the document and wait for it to be updated via the cloud. Then reload their version of the document with VisCon and make your edits. The other person must NOT save or edit the document until you are finish editing. When your changes are saved the other person can simply reload your version of the document, and both of your edits are intact. But be careful!

Exporting documents from VisCon

You export a document from VisCon by doing the following:

  1. Go to the file menu and select “Save as” or press commando-shift-s on mac or Control+shift+s on Windows.
  2. A standard save as-dialog box will be shown. Here you can decide the filename for the document, the document format and where to save it.
  3. Press enter/return to activate the save button or simply click the “Save” button when you are ready to save your document.

If you choose any other format than Markdown or plain text, the export will start automatically.
VisCon checks your content of the document and exports it to the chosen format.

Important when importing and exporting documents

Important: Please read this paragraph carefully before importing and exporting documents with VisCon. We have found some limitations and issues which we have listed below.

  • After importing a document, VisCon will remember the filename and format. It is therefore easy to save the document but by mistake overwrite the original version of the document unintentionally. Therefore we strongly recommend that you save your edited document as plain text or Markdown.

  • If you import a HTML-document into VisCon you may see some metadata like title, generated by etc. It is safe to remove this text if you just want the important content. VisCon will automatically create the necessary metadata next time you export the document.

  • When converting to Markdown you may notice some indentations in lists. This is due to the way VisCon at the moment converts Markdown. We are working on fixing this. You should know however, that if you encounter any changes in Markdown formating that this will not affect your result when converting to HTML, Microsoft Word or any other format.

    ## Working with multiple documents

VisCon allows you to switch between open documents. When you launch VisCon you will always see a new, empty document “New 1.” From here you can just start writing, or you can simply open an existing document.

If you want to, you can always make a new document. VisCon then creates a new document.

You can see all open documents by pressing control+tab on either Mac or Windows. When you do so, VisCon shows a list of all the documents you have opened since you launched VisCon. Just locate the document you want, and press enter/return or click the “OK” button.

At the bottom of the list, there is a “New” option, which you can choose if you want to make a new document without leaving the list of open documents.

Previewing a document from VisCon

At some point you may want to watch your document and your progress. Go to the tools menu and select “Preview.” You can alternatively press command-p on mac or Control+p on Windows.

VisCon will then convert your document to HTML, and open it in your default web browser of choice. If you want to change anything after you have watched the result in your browser, just go back to VisCon and make the change. Now, you can go back to your browser and refresh the page. Your changes are shown immediately. This is especially good if you just want to practice your Markdown skills and don’t need to save your document before previewing the result.

You can copy some or all the text with formating from your browser as you normally would, and paste the content into another application of choice.

Let’s say you want to make an email with headings and a bulleted list. Just write the message with the appropriated headings and bullet points inside VisCon and preview the result. When you open your browser with control+P or Command-P, you can just review the result, and at last copy it into your favorite mail client of choice and send it.

Note: VisCon will always clear the files you preview in your web browser as soon as you quit VisCon and shut your browser down. No data is sent outside your computer, so previewing a document can be done even if you have no internet connection.

Preferences dialog

You can customise VisCon through the preferences dialog. The categories are placed in a combobox.
The preferences dialog consists of the following categories which are explained in the next paragraphs. After setting the preferences the way you like, simply press the “OK” button to save your changes, or press “Cancel” to discard all the changes you have made.

General preferences

The general preferences consists of the following settings:

  • Automatically check for updates. If this checkbox is unchecked VisCon will not check for updates when it launches. This is checked by default.

  • Enable spell checker: If this checkbox is checked it is possible to spell check documents in VisCon.

    Note: This is currently only available on the Mac OS version of VisCon.

  • Language: Here you will find a list of languages which VisCon supports. In order for the language to change, you must exit VisCon and open it again.

    Note: For any other language than English the translations are autogenerated. If you encounter mistakes, please contact us

Advanced preferences

The advanced category consists of the following items:

  • Enable debug mode: When debug mode is enabled VisCon will log extra information to the log file. This is useful if you encounter a bug or if VisCon shows you an error message. If this checkbox is unchecked no log file will be generated, and if an error shows up VisCon will not show as many details.
  • Text wrap: Allows the following options for text wrapping:
    • Default: Wrap the lines at word boundaries or at any other character if there are words longer than the window width.
    • Word Wrapping: Wrap the lines too long to be shown entirely at word boundaries.
    • Character Wrapping: Wrap the lines too long to be shown entirely at any position.
    • Don’t Wrap: don’t wrap at all, show horizontal scrollbar instead. When this option is selected, you will move down until there is a line break. A line break is defined as a newline, that means a press on the enter/return key on your keyboard.
  • Encoding to use when opening text and markdown files: By default the default setting “Respect the files original encoding” is recommended. If you change this option to any other format VisCon will try to open any markdown or txt-file with the selected text encoding. But in cases where the encoding does not match the file you are opening, you will get a warning saying that VisCon could not open the file with the preferred text encoding. VisCon asks if it should try to guess the correct text encoding for you. If you press “Yes”, VisCon will try to guess the right encoding. If you press “No”, you will return to the main window, and you will need to change your preference here.
  • Encoding to use when saving text and markdown files: By default the default setting “Respect the files original encoding” is recommended. If you change this to any other text encoding, VisCon will automatically save your Markdown or txt-file as the text encoding you have selected here. This is useful if you want to preview a document, but want to preserve a specific text encoding.

Note: Regardless of your preferences for opening and saving Markdown and txt-files, VisCon will always convert your opened documents to UTF-8 when you preview and edit the document. In almost any case this should not pose any problems at all. This is done, so the preview feature can handle your document. VisCon will always respect the encoding you select for saving, so when you save your document, it is automatically converted to the encoding you chose in preferences for saving.

Get in touch

In this chapter you will find all the different ways to contact us. We really want to hear from you!

Support

Subscribe to our mailing list

You can get help by subscribing to our VisCon-mailing list. This list will be the main area where users can help each other, suggest features and mention potential issues they may encounter while using VisCon. This list can also be used if you have questions about the Markdown format.

To subscribe to the mailing list, just send an empty email to:

If you ever want to unsubscribe from the mailing list, just send a blank email to:

If you have encountered a problem or a bug

If you believe you have found a bug in VisCon, please submit an issue on Github.
You can find our issue-tracker here:
https://github.com/Accessiware/viscon/issues

If you don’t want to use Github, you are welcome to share your experience on the VisCon-mailing list. If it is a bug we will create an issue on Github based on your experience.

Contact us directly

Your feedback is valuable to us. Please contact us via our contact form at:
https://visconapp.com/contact-us
or send us an email directly at:

You can also tweet us at: Accessiware

appendixes

Appendix 1: An introduction to Markdown

The purpose of Markdown is to make formatted documents easy to read. Markdown was invented by John Gruber

Ever since it began back in 2004, Markdown has evolved extensively over the years. There are now multiple specifications of Markdown. Some of the more popular Markdown variants are MultiMarkdown, PHP Markdown Extra, Strict Markdown, and GitHub flavored Markdown. One thing all these variants have in common is that they are easy to read and write. You can, in fact, write in different flavors without harming your document.

Depending on your projects, there are no right or wrong way to start learning Markdown. However, we strongly recommend that if Markdown is brand new for you, it is best to start reading Markdown, invented by John Gruber
On this site, you will find the philosophy behind Markdown and a general syntax guide.

Do not try to learn it all, but instead search for the format elements you want, and take it in small steps.

And best of all: Contact us or someone you may know who can assist you with Markdown if you need it.

Useful Markdown resources

Below you will find documentation for the most popular variants of Markdown. We recommend that you start with the Strict Markdown at first, if Markdown is all new to you.

Credits

  • Coding, design and programming: Accessiware, Nicklas Tegner

  • Idea and concept: Thomas Byskov Dalgaard

  • Documentation: Thomas Byskov Dalgaard

  • Our wonderful beta testers:

    • Søren Jensen
    • Annie Skov Nielsen

Appendix 2: Version History